Search box for Activity log won't clear #bug


Andy
 

This is an annoyance, but not a huge problem.

Group Moderator actions:
1.  Click Admin > Activity to display the Activity Log.
2.  Type something into the Search box and click the Search button.
3.  Now clear the Search box, and click the Search button again, which should restore the full un-filtered Activity Log.
4.  Surprise -> the previous contents of the Search box re-appear!  And I'm seeing the filtered Activity Log.
5.  The same thing happens if anything is selected from the list of Activity Actions.  The Search box always reverts to what was there previously.  Except ...
6.  Except if my search string had an asterisk, which gets replaced by %2A when it reverts to the old text.  Now it is actually searching for "2A" and ignores the "%".  (I guess "%" is not an allowed search character?)

The work-around is to start over:  click "Activity" in the left menu again.  So it is an annoyance but not a show-stopper.

Andy


Duane
 

On Thu, Apr 8, 2021 at 10:49 PM, Andy wrote:
This is an annoyance, but not a huge problem.
It's been that way for as long as I can remember, so I wouldn't call it a bug, more a suggestion for improvement.

Duane


Andy
 

Duane says that it's always been like that.

Just the same, I would call it a bug because it isn't right.  If I do a search with an empty search field, it should search with that criterion and not something else that isn't there.

Andy


Andy Wedge
 

On Fri, Apr 9, 2021 at 01:26 PM, Andy wrote:
Duane says that it's always been like that.

Just the same, I would call it a bug because it isn't right.  If I do a search with an empty search field, it should search with that criterion
The search field on the member list does something similar. If you try and blank that out, it uses the previous search criteria.

Andy