Memberlist browsing as a member malformed URL 404 error #bug


 

Hi Mark,

If someone enables access to the MemberList for regular members, when a member is browsing the list and clicks on anyone's row link, they get a 404 error.  Seems the URL for that link is malformed, it's missing group info and also the @.  The same works fine for admin access, at least an owner, didn't test with a regular mod.

As the owner, the URL I get when I click on the linked profile after going through the MemberList is:
https://groups.io/g/groupname/profile/@someuser

But as a member, I get this:
https://groups.io/profile/someuser which returns the 404 error

Cheers,
Christos


Pete Cook
 

I'm perplexed - when I view the member list in a group for which I'm not a moderator or owner, there are no row links.

Pete


 

On Wed, Apr 27, 2022 at 10:52 AM Christos Psarras <christos@...> wrote:

If someone enables access to the MemberList for regular members, when a member is browsing the list and clicks on anyone's row link, they get a 404 error.  Seems the URL for that link is malformed, it's missing group info and also the @.  The same works fine for admin access, at least an owner, didn't test with a regular mod.

As the owner, the URL I get when I click on the linked profile after going through the MemberList is:
https://groups.io/g/groupname/profile/@someuser

But as a member, I get this:
https://groups.io/profile/someuser which returns the 404 error

This has been fixed. Note that if a user's profile is not accessible to the member, then they will be redirected to the group home page.

Thanks,
Mark 


 

Hi Mark,

>>> This has been fixed.

It looks like you forgot to add the @ before the UserName in the URL as it still redirects when it shouldn't.


>>> Note that if a user's profile is not accessible to the member, then they will be redirected to the group home page

Here's where it got weird, because the first time it didn't work out like this, so I kept on testing it on different groups.  In the end, for 4 groups it redirects to the YourGroups home page, not the group one, but in 4 other groups it does redirect to the Group home page.  Seems if a group has subgroups it redirects to the Group home page, if not it redirects to the YourGroups home page, so possibly it's something addressing-related?

Cheers,
Christos


 

On Wed, Apr 27, 2022 at 3:14 PM Christos Psarras <christos@...> wrote:
Hi Mark,

>>> This has been fixed.

It looks like you forgot to add the @ before the UserName in the URL as it still redirects when it shouldn't.

Whoops. Fixed.

Thanks,
Mark