moderated links to photos inconsistent #suggestion #bug


Jen Weber
 

I have noticed that when viewing a photo in an album, right clicking the photo and selecting "Copy Link Address" gives an incorrect address.
It seems to be sending someone to a position 1 photo earlier in the album.

For example, when I'm on this page (copying the url at the top of the browser:)
https://temarichallenge.groups.io/g/Main/photo/3792/2?p=Created,,,20,2,0,0

and I right click "copy link", this is what is pasted:
https://temarichallenge.groups.io/g/Main/photo/3792/1?p=Created,,,20,2,0,0

Sending me to an earlier photo. 


I want to take this opportunity to once again BEG for coding the photo albums to generate a stable URL that does not refer to a position in the album, but rather to a unique identifier of the photo.  I know this has been brought up before, but it is so frustrating that as soon as an album's contents are added to or changed, all of the messages with links to anything in that album are all pointing to the wrong things.  

My 900 person group (and other groups)  rely heavily upon photos and discussions of them.  One of the main objectives is to keep accurate archives of our ideas and conversations, and the fact that these links "expire" is really devaluing our archived messages and information.  

Please, can I do anything to help make this rework of picture ID'ing happen?  I'm desperate, as are many of my colleagues. Photos and discussions are why our groups exist, and this not working for us is just not ok.

Thanks for your help.

Jen Weber


 

On Tue, Apr 6, 2021 at 7:58 AM Jen Weber <jenkweber@...> wrote:
I have noticed that when viewing a photo in an album, right clicking the photo and selecting "Copy Link Address" gives an incorrect address.
It seems to be sending someone to a position 1 photo earlier in the album.

That's expected. The left half of the photo is one big link to the previous photo and the right half of the photo is one big link to the next photo. (corresponding to the left/right arrows).

I want to take this opportunity to once again BEG for coding the photo albums to generate a stable URL that does not refer to a position in the album, but rather to a unique identifier of the photo.  I know this has been brought up before, but it is so frustrating that as soon as an album's contents are added to or changed, all of the messages with links to anything in that album are all pointing to the wrong things.  

I have changed the URL structure for viewing photos so that now the URLs refer to specific photos and not to a relative position in an album. This means the URLs will no longer change when photos are added/removed from an album.

Cheers,
Mark 


Judy F.
 

Yippee!!!!  Thanks Mark.
Judy F.
SW Florida - USA


On Tue, Apr 6, 2021 at 01:02 PM, Mark Fletcher wrote:
On Tue, Apr 6, 2021 at 7:58 AM Jen Weber <jenkweber@...> wrote:
I have noticed that when viewing a photo in an album, right clicking the photo and selecting "Copy Link Address" gives an incorrect address.
It seems to be sending someone to a position 1 photo earlier in the album.

That's expected. The left half of the photo is one big link to the previous photo and the right half of the photo is one big link to the next photo. (corresponding to the left/right arrows).
 
I want to take this opportunity to once again BEG for coding the photo albums to generate a stable URL that does not refer to a position in the album, but rather to a unique identifier of the photo.  I know this has been brought up before, but it is so frustrating that as soon as an album's contents are added to or changed, all of the messages with links to anything in that album are all pointing to the wrong things.  

I have changed the URL structure for viewing photos so that now the URLs refer to specific photos and not to a relative position in an album. This means the URLs will no longer change when photos are added/removed from an album.
 
Cheers,
Mark