moderated Error message on trying to attach files #bug


 

A group member is receiving an error message on trying to attach files to his messages, and then the second time he tries, the attachment goes through and everything is fine. The first try, he gets this error message:

Syntax error: unexpected token < in JSON at position 2


and the file fails to attach, but otherwise the message goes through normally. He then tries again and gets no error message and the message comes through with the attachment. This has happened to him twice within a few days. The first time it was a pdf, and the second time it was a jpeg.

I've already sent details to Mark at support but am posting here in case anyone else wants to add that they've also experienced this.
--
J

Messages are the sole opinion of the author, especially the fishy ones.
My humanity is bound up in yours, for we can only be human together. - Desmond Tutu


 

I just heard back some details from the group member. The first time, he was attaching a pdf. The second time, he was inserting a jpeg. Both times, he got an error message and failure with his first try, but he's not sure it was the same error message. And both times, his second try went through without issue..
--
J

Messages are the sole opinion of the author, especially the fishy ones.
My humanity is bound up in yours, for we can only be human together. - Desmond Tutu


 

Mark,

I just tried to send a bug report message to this group, and insert (not attach) a screenshot of the error, and I got the exact same error my group member got. It's been difficult and confusing to report here, because I was trying to insert a screenshot OF THE ORIGINAL ERROR (which involved the "improved draft saving" and error "there was an error saving the draft," multiple times), but when I tried to insert those screenshots, I got the OTHER error regarding insertion of the screenshot. So the insertion error message was appearing BELOW the draft-saving error message. This is real. I'll try it again and next time, will try to attach (not insert) the screenshot.

Meanwhile, the "improved draft saving" error message bug is still there, at least in the non-test-version. Can we get an update on whether and when that is fixed in the currently running (non-test) version? Otherwise I don't know whether to continue to report the bugs.
--
J

Messages are the sole opinion of the author, especially the fishy ones.
My humanity is bound up in yours, for we can only be human together. - Desmond Tutu


 

Well, that was interesting (or useless?). I got the same behavior my group member experienced, namely, it happened on the first attempt but not on the second. Seems flakey. I should note that the situation is that I'm trying to insert (not attach) a screenshot, which is a png. Maybe that's not what "insert picture" acts on, maybe that only accepts a jpg? If so, then there should be a comprehensible error message (e.g., "you can only insert jpgs") instead of the jabberwocky it puts out.
--
J

Messages are the sole opinion of the author, especially the fishy ones.
My humanity is bound up in yours, for we can only be human together. - Desmond Tutu