Topics

moderated #bug #bug


admin fali.org
 

For about 3 days now I have been getting multiple message, 20+ as a guesstimate,  for some of our messages that are posting. I am the group moderator but some of our members are complaining of the same problem. This could be a major deterrent to them remaining with this group which is an important part of our membership. Please help as soon as possible. Our email boxes are filling up with messages that have already been handled.

Amy O'Rourke
admin@...


 

On Tue, Aug 11, 2020 at 10:16 AM admin fali.org <admin@...> wrote:
For about 3 days now I have been getting multiple message, 20+ as a guesstimate,  for some of our messages that are posting. I am the group moderator but some of our members are complaining of the same problem. This could be a major deterrent to them remaining with this group which is an important part of our membership. Please help as soon as possible. Our email boxes are filling up with messages that have already been handled.


The problem is with Network Solutions, your email provider. After we send the body of an email to them, we have to wait for a response, indicating that they got the message ok, or if there was an error. The issue is that they're not responding back to us in a timely manner. We timeout and have to try sending the message again, because we're not sure they received it. Normally this shouldn't be a problem because email providers can tell if they've received a message more than once, because each email has a unique identifier, called the Message-ID. Get two emails with the same Message-ID, and you know you've gotten a duplicate and can throw one away. But it appears Network Solutions is not doing that. So the combination of those two things means you could end up with a bunch of duplicate emails.

I just changed how long we wait for an answer after sending the email body. So maybe that will fix it for you. But my suggestion is to complain to them, because they're having problems and need to fix them.

(Also in the future, please try to use a more descriptive subject line. I normally edit them if they are not descriptive before I approve the messages, but this one slipped by).

Thanks,
Mark