moderated Weird topic-locking behavior in a particular group #misc #bug


 

Hi Mark,

Something weird may have gotten inadvertently introduced today, this just happened on a group of mine.  It almost looks like the system locked-topic notice gets sent or posted to the group as a new message (and topic) when I lock a regular topic.

I locked a topic and all seemingly happened as usual, except a message was now somehow sent (or just posted) to the group, containing the usual system notice:
Hello,
The topic you're attempting to reply to has been locked by the moderators.  If you believe you still need to reply to it please email the admins at alps+owner@alps.groups.io with your reply message text and explaining why you should be able to reply to that locked topic.
Thanks You.
The Group Admins

Looking at the headers online:
From: "ALPS Micro Dry printers Group Moderators" <ALPS+owner@ALPS.groups.io>
To: "ALPS@ALPS.groups.io" <ALPS@ALPS.groups.io>
Subject: [ALPS] Re: Help
Date: Mon, 09 May 2022 14:56:21 -0700
Message-ID: <lhuw.1652133381238059146.6hmr@groups.io>
Precedence: Bulk

Looking at the headers in Tbird:
From: "ALPS Micro Dry printers Group Moderators via groups.io" <ALPS+owner@...>
To: "ALPS@ALPS.groups.io" <ALPS@ALPS.groups.io>
Subject: [ALPS] Re: Help
Date: Mon, 09 May 2022 14:56:21 -0700
Message-ID: <lhuw.1652133381238059146.6hmr@groups.io>
Sender: ALPS@ALPS.groups.io
List-Id: <ALPS.ALPS.groups.io>
Mailing-List: list ALPS@ALPS.groups.io; contact ALPS+owner@ALPS.groups.io
Delivered-To: ALPS@ALPS.groups.io
And there is more weirdness about this:

- There's nothing in the log regarding this stray message, just the normal topic-locking entry for the original topic.
- A new topic with the same title as the locked topic gets created.  If I unlock and relock that same original topic, another notice gets sent to the group and it now threads under the newly-created stray topic.
- I can lock that stray new topic and in that case no additional message gets generated.
- Message moderation doesn't seem to make a difference, at least the "Moderate First Topic Message" vs Unmoderated.
- I can reproduce this in the above (premium) group but I cannot reproduce it in a free test group or another premium group, locking a topic there behaves normally.  I didn't test any more groups.

I tried the usual clear & restart browser, different browser, different PC, log out & back-in, didn't help.  I did upload a few PDFs and created a generic link (to a group topic) in Files in this group but that shouldn't make any difference.

I left for now those newly-created stray topics in that group for your examination.

Cheers,
Christos


 

OK, I think I figured out what's going on.

This particular group has a LockedTopic notice and is active.

When locking a topic using the TopicProperties method, when one clicks on LockTopic they are presented with a dropdown which defaults to using the LockedTopic notice if it's active, otherwise defaults to Don't Send. 



If one uses the direct link LockTopic method, this happens transparently.

Fine, I get this part, but shouldn't that notice be sent to a member who tries to reply to this topic?  In this case that notice gets posted to the group instead when I lock the topic which doesn't make that much sense, to me at least.  If I'm doing archive maintenance, why would I want to saturate the message archive with FYI messages that I'm locking some topic?  Shouldn't the default be No message unless if I actively set it on?  On top of that, the blurb says "Message to send to the group when locking a topic."  Again, I was under the impression this would be the notice sent to the poster, not to the group.  We cannot have more than one active LockedNotice so this is not a case of having two notices, one sent to the poster if they try to reply and another one posted to the group when I lock a topic as an FYI.

So I'm a bit confused, either I'm not fully understanding the expected process or something is not quite right with what's currently happening.

And the reason I initially missed this is because I was using the direct link lock method (where this happens transparently) and when locking the topic that way, if one goes to the TopicProperties afterwards they see this:



Notice how the dropdown is not showing now?  One has to uncheck and recheck the Locked checkbox in order for the dropdown to show up again, so it's easy to miss what's going on.

Cheers,
Christos


 

OK, I see it is a "group" FYI notice after all, so that part is fine, bad interpretation on my part.  The last part in my previous message though, about the notice dropbox not showing afterwards in TopicProperties, is a bug and should be fixed.

Another thing that added to the confusion is that the owner's manual doesn't explicitly mention in the "Locked Topic notice" section that this notice is a "group" notice and gets sent to the group and not to any poster who tries to reply.  It is mentioned in the two later sections, "Locking topics" and "Editing the properties of topics in the archive", but those two come further down in the manual so if one reads just the "Locked Topic notice" section they can miss that bit.

Cheers,
Christos


 

Hi,

The locked topic notice was not being sent to the group on topic locking. I have fixed that now.

Thanks,
Mark