moderated Editing toolbar is missing when Editing an existing message #bug


Andy I
 

I think this is a bug.

In the web interface on a PC, when writing a new message or a reply, there is a toolbar across the top of the text editing box, with 'buttons' for text formatting (bold, italic, bullets, justify, etc.).

However, when Editing an existing message - at least when a Moderator edits someone else's message - that toolbar has gone missing.  Today there is a greyed-out bar where it should be, but there are no 'buttons' and no actions if I hover the mouse in that area.  Where did the editing controls go?

Andy


Andy I
 

I just double-checked this.  I'm a Moderator, and ...

When editing my own message, I still see the toolbar.

When editing someone else's message, even if it's another Moderator's message, the toolbar is greyed-out and missing all buttons.

Was this intentional?  If it is, why?

When editing someone else's message, I can't even use ctrl-key shortcuts (such as ctrl-B, ctrl-I, ctrl-U) to affect any formatting of the text.  Indeed, ctrl-U opens up a rather large HTML page in a new tab, rather than underlining the highlighted text.  (Did Groups.io do that, or is it Chrome intercepting ctrl-U in that case?)

Andy


Duane
 

On Thu, Jan 20, 2022 at 12:03 PM, Andy wrote:
However, when Editing an existing message - at least when a Moderator edits someone else's message - that toolbar has gone missing.
I think it depends on how the message was composed/sent.  If it was plain text, as it would be on a plain text only group or the user sent it as PT, no formatting is available.  I haven't tried all possible combinations though.

Duane


Bruce Bowman
 

On Thu, Jan 20, 2022 at 01:16 PM, Andy wrote:
When editing my own message, I still see the toolbar.

When editing someone else's message, even if it's another Moderator's message, the toolbar is greyed-out and missing all buttons.

Was this intentional?  If it is, why?
Andy -- I believe if you want the formatting toolbars to show up every time, you have to select "Force HTML Emails" in your group settings.

Regards,
Bruce


Andy I
 

I think you are right.  As it happens, all the messages I tried this on, had narrower margins so they probably were plain text.  I found others that weren't, and viola, the toolbar was there!

Thank you.

I'm not comfortable changing the email delivery, just to make editing work differently for the messages displayed in the web interface - and anyway that just seems counterintuitive.

Andy