moderated All sorts of surprises just now #bug


Duane
 

I had just typed a bug report with details about the Pending Members and Pending Messages having problems, possibly related to drop down boxes.  When I clicked Send, it was immediately sent to a Draft, but most of the information was gone.  I'm hoping there's a problem with the site that is leading to the problems in multiple areas, maybe related to the database connection problem seen a couple of days ago.  If not, I'll post individual reports.

Thanks,
Duane


Andy
 

Duane, were you typing a reply to an existing message?

If the message you are replying to is deleted before you press the green "Reply to Group" button, the symptoms you described happen.  I think that's the same thing in https://beta.groups.io/g/main/message/29566

In all likelihood there are things that can foul up the works when actions happen in unexpected order, and it's hard to plan for all of them.

Andy


Duane
 

On Sat, Jul 24, 2021 at 04:27 PM, Andy wrote:
Duane, were you typing a reply to an existing message?
No, this was moderating the group, both messages and members.

Duane


Linda
 

I tried posting earlier about the problem moderating messages. Couldn't get rid of the pending message by approving or rejecting. Delete finally worked.

My message to this group wound up in drafts. I've since deleted it.


 

On Sat, Jul 24, 2021 at 1:09 PM Duane <txpigeon@...> wrote:
I had just typed a bug report with details about the Pending Members and Pending Messages having problems, possibly related to drop down boxes.  When I clicked Send, it was immediately sent to a Draft, but most of the information was gone.  I'm hoping there's a problem with the site that is leading to the problems in multiple areas, maybe related to the database connection problem seen a couple of days ago.  If not, I'll post individual reports.

Hmmm. This morning, I updated one of the 5 webservers with some changes to better log/trace database calls (as part of the work to figure out what happened the other day). The changes are supposed to be transparent, but apparently something got screwed up. I've taken that webserver out of rotation and I will need to track down the problem. Please let me know if you see any other gremlins.

Thanks,
Mark 


 

Hi Mark,

Please let me know if you see any other gremlins
I just noticed a weird one, a reply to the Welcome Notice (quoted) in one group by someone with the gio munged address, saying they never subscribed.

I checked and that email address in not in that group, present or past.

Seems the Welcome Notice message was sent to them on Jul 24, 2021, at 7:30 PM (based on the quoted text), and they replied on 7:52, same time as it was logged in the log under "Message to +owner" (as it would normally be when a member sent it), but there was no attempt by that address to join, nor there is anything else in the log anywhere (besides the above entry), either on the main or the subgroup logs or under "Non-member message" where the typical spam log entries show.

I didn't reply to it (and told the other mods not to, just in case) but it does look legit, I can send the pertinent info off-list.

Cheers,
Christos