Menu problem with older computers #bug


Steve Hayes
 

For a few months I had problems with the groups.io main menu.

The "Your Groups" item at the top, and the "Admin" item did not work.

A few weeks ago they started working again, and I was happy, but then a week
or two ago they stopped working again -- it looks as as though someone
reloaded the defective version from a backup.

I asked about this on the GMF forum, and it appears to affect only older
computers (mine runs Windows XP Service Pack 3 and Firefox v41 (later
versions of Firefox are bloatware).

As all the other menu items work OK, would it be possible to fix those two to


work for those of us who are pensioners and can't afford to buy the latest
hardware to run the latest bloatware every couple of years?


--
Steve Hayes
E-mail: shayes@dunelm.org.uk
Blog: https://methodius.blogspot.com/
Web: http://www.khanya.org.za/stevesig.htm
Phone: 083-342-3563 or 012-333-6727
Fax: 086-548-2525


Bruce Bowman
 

On Thu, Jul 22, 2021 at 01:23 PM, Steve Hayes wrote:
The "Your Groups" item at the top, and the "Admin" item did not work.

A few weeks ago they started working again, and I was happy, but then a week
or two ago they stopped working again -- it looks as as though someone
reloaded the defective version from a backup.
Steve -- It sounds as if you've somehow disabled Javascript in Firefox. These pull-down menus require Javascript to work.

Instructions to turn it back on can be found at https://support.mozilla.org/en-US/kb/javascript-settings-for-interactive-web-pages 

Regards,
Bruce


Steve Hayes
 

On 22 Jul 2021 at 13:03, Bruce Bowman wrote:

Steve -- It sounds as if you've somehow disabled Javascript in Firefox.
These pull-down menus require Javascript to work.
But why then do all the other menu items work, and it is just the "Your
Groups" and "Admin" ones that do not?


--
Steve Hayes
E-mail: shayes@dunelm.org.uk
Blog: https://methodius.blogspot.com/
Web: http://www.khanya.org.za/stevesig.htm
Phone: 083-342-3563 or 012-333-6727
Fax: 086-548-2525


Rubens
 

...
BB> Steve -- It sounds as if you've
> somehow disabled Javascript in
> Firefox.

SH| But why then do all the other menu
| items work, and it is just the "Your
| Groups" and " not Admin" ones that do?


In this case, it sounds as you logged
into Groups.io using an email account
that is NOT the same account you use
as the Group Owner.

If you use an email account Groups.io
does not recognize as belonging to an
owner/moderator, then no "Admin" menu
appears for you.


[ ] Rubens






.


Bruce Bowman
 

On Thu, Jul 22, 2021 at 11:09 PM, Steve Hayes wrote:
But why then do all the other menu items work, and it is just the "Your
Groups" and "Admin" ones that do not?
They don't work because they're pull-down menus. The others are just buttons.

Regards,
Bruce


Steve Hayes
 

On 23 Jul 2021 at 6:22, Bruce Bowman wrote:

On Thu, Jul 22, 2021 at 11:09 PM, Steve Hayes wrote:


But why then do all the other menu items work, and it is just the "Your
Groups" and "Admin" ones that do not?
They don't work because they're pull-down menus. The others are just buttons.
I'm asking if it would be possible to fix them so that they do work. Is there
a rule that says pull-down menus should not work?

They used to work, then they stopped working, ten they worked again for a few
weeks, then they stopped working.

It would be nice if they worked again. so I can moderate and approve posts
etc.
--
Steve Hayes
E-mail: shayes@dunelm.org.uk
Blog: https://methodius.blogspot.com/
Web: http://www.khanya.org.za/stevesig.htm
Phone: 083-342-3563 or 012-333-6727
Fax: 086-548-2525


Duane
 

On Fri, Jul 23, 2021 at 09:32 AM, Steve Hayes wrote:
Is there
a rule that says pull-down menus should not work?
Since they require javascript, yes, there's a rule that says they won't work if you don't have it enabled.

Duane


Rubens
 

...
SH| But why then do all the other menu
| items work, and it is just the "Your
| Groups" and "Admin" ones that do not?

BB> They don't work because they're
> pull-down menus. The others are
> just buttons.

SH| I'm asking if it would be possible
| to fix them so that they do work.


Steve, and we are telling you that
the problem probably might be with
your computer.

If you are accessing Groups.io without
log in with a administrator account,
for example, the symptoms will be
exactly the ones you mentioned: no
admin menus will appear at all (neither
"Your Groups", nor "Admin"). Just the
users' menus will appear in this case.

Or if you (or something) turn off
the Javascript option.

Please, have you checked if you are
logged in with your groups administrator
account?


[ ] Rubens






.


Steve Hayes
 

On 23 Jul 2021 at 7:40, Duane wrote:

On Fri, Jul 23, 2021 at 09:32 AM, Steve Hayes wrote:


Is there
a rule that says pull-down menus should not work?
Since they require javascript, yes, there's a rule that says they won't work
if you don't have it enabled.
And is there a rule that says they won't work if I do have it enabled?

Was Javascript added, then removed, then added again, so that they worked,,
stopped working, started working again and stopped working again?

Since there was a working version a few weeks ago, could it not be restored,
Javascript or no Javascript?


--
Steve Hayes
E-mail: shayes@dunelm.org.uk
Blog: https://methodius.blogspot.com/
Web: http://www.khanya.org.za/stevesig.htm
Phone: 083-342-3563 or 012-333-6727
Fax: 086-548-2525


 

Steve,

Maybe update FF to the latest XP-supported version, 52.9.0 ESR?  I have that, along with Chrome 49.0.2623.112 & Opera 36.0.2130.80 in my XP test partition and they all work fine.

Out of curiosity, did you add recently or already had a Script blocker add-on?  If so, could it be it's the one misbehaving and causing this?

Also, here's a few temporary workarounds you could do, so at least you can get to the pending messages:

1. Go to / create a bookmark to https://groups.io/groups , or click on the "Groups.io" link on the upper left of the screen, and in there, any pending messages will show under the ApprovalsNeeded column as a link and you can go to them this way.

2. Create a bookmark to https://groups.io/g/yourgroupname/pending .  This will take you there and should also expand the Admin menu on the left so you can get to the other admin options.

3. Create a bookmark group in the toolbar and add in there all the bookmarks that take you to the groups and/or specific group areas/functions, sort of replicating the "Your Groups" menu.  (you may want to do that anyway, I've done it because it's faster than getting to something the "normal/regular" way)

Cheers,
Christos


 

Hi All,

My guess is that the issue came up when I re-organized the various javascript libraries that the site uses. Previously, the libraries were specified in the HTML as individual files. Now they are all bundled into one file. I did this for a couple reasons. One, it speeds up website loading. It also makes it easier for me to track changes. And, importantly, it's needed for the app.

My guess is that his browser doesn't like something in the bundled javascript file. I don't know what, and I can't reproduce it. Rolling back to the old way is not an option.

Thanks,
Mark


Steve Hayes
 

On 23 Jul 2021 at 11:50, Rubens wrote:

Please, have you checked if you are
logged in with your groups administrator
account?
I have only one account that I log in with. I changed nothing on my computer
between the menus working and when they didn't.

The only thing that would turn off Javascript is the "NoScript" extension to
Firefox, and I have it enabled for the whole of the groups.io site.


--
Steve Hayes
E-mail: shayes@dunelm.org.uk
Blog: https://methodius.blogspot.com/
Web: http://www.khanya.org.za/stevesig.htm
Phone: 083-342-3563 or 012-333-6727
Fax: 086-548-2525


Steve Hayes
 

On 23 Jul 2021 at 10:18, Christos G. Psarras wrote:

Maybe update FF to the latest XP-supported version, 52.9.0 ESR?  I have that,
along with Chrome 49.0.2623.112 & Opera 36.0.2130.80 in my XP test partition
and they all work fine.
Unfortunately the later versions of Firefox don't work too well on my
computer -- particularly the ones where they introduced "pockets". They are
memory hogs (bloatware), and spend inordinate amounts of time swapping to
disk. One problem with older computers is that extra memory boards are not so
easy to come by.

Out of curiosity, did you add recently or already had a Script blocker
add-on?  If so, could it be it's the one misbehaving and causing this?
As I said in another message, I use NoScript -- mainly to prevent news sites
from automatically playing videos -- but it is set to enable everything for
the groups.io site, which is set as "trusted".

1. Go to / create a bookmark to https://groups.io/groups , or click on the
"Groups.io" link on the upper left of the screen, and in there, any pending
messages will show under the ApprovalsNeeded column as a link and you can go
to them this way.
Thanks, that sounds like a useful workaround.

I can work-around the Your Groups thing by just entering the group URL
directly into the browser, to the browser, and I suppose I could create a
local HTML page with all the relevant addresses, including the admin ones,
which would effectively be my own local menu for groups.io, but it would be
nice if it could be fixed in case there are other users with older computers.






--
Steve Hayes
E-mail: shayes@dunelm.org.uk
Blog: https://methodius.blogspot.com/
Web: http://www.khanya.org.za/stevesig.htm
Phone: 083-342-3563 or 012-333-6727
Fax: 086-548-2525


 

On 24 Jul 2021 at 3:47, Steve Hayes wrote:

I can work-around the Your Groups thing by just entering the group URL
directly into the browser, to the browser, and I suppose I could create a
local HTML page with all the relevant addresses, including the admin ones,
which would effectively be my own local menu for groups.io, but it would be nice
if it could be fixed in case there are other users with older computers.
Steve,

It isn't a simple matter of older computers. I have no problems using Opera
36.0.2130.80 with XP, and there has been no change to that just recently.

Jim