moderated Unable to set web notifications in Firefox mobile #bug


Andy Wedge
 

On Wed, Apr 21, 2021 at 03:51 PM, Derek Milliner wrote:
I went in to the 'Settings/Notifications' on the S7 and found that notifications from Chrome were disabled under 'APP NOTIFICATIONS'. Enable that, and hey presto - get Groups.io notifications in both FF and Chrome.
I'd already checked that before reporting the issue and app notifications are enabled for Firefox and Chrome. I even tried disabling and then re-enabling them but that didn't help either.

Andy


Derek Milliner
 

Andy/Mark,

For what it's worth, I've checked this on my Galaxy S20 in Chrome and Firefox (87 rc1, not the beta 88) and no problem getting the notifications. FF was a fresh install from the play store and I took the most 'locked-down' options in the first run setup, apart from defaulting to incognito.

Trying the same thing on a Galaxy S7 that I haven't got around to recycling yet (!); I got the notifications for the FF browser but not, interestingly, Chrome. Until, that is, I went in to the 'Settings/Notifications' on the S7 and found that notifications from Chrome were disabled under 'APP NOTIFICATIONS'. Enable that, and hey presto - get Groups.io notifications in both FF and Chrome.

In summary; looks like it's down to individual 'phone settings rather than anything on the Groups.io side

Cheers,

Derek


Andy Wedge
 

On Tue, Apr 20, 2021 at 10:16 PM, Mark Fletcher wrote:
Is there any additional information you can provide to help me figure out the problem?
Hi Mark,

I'm not sure if it's relevant but this morning, I see this this in Firefox on my laptop (Win 10 Pro version 20H2):




Notifications were not working as they were last night but clicking the Enable button again reset things so they are OK now.

My Firefox browser bookmarks and active pages etc. are synchronised between my laptop and mobile phone via my Firefox account so if there is an issue on one device with Firefox, I can understand why that may impact the other device. I'm not sure how that would explain what I see on Chrome mobile though.

Andy


Andy Wedge
 

On Tue, Apr 20, 2021 at 10:16 PM, Mark Fletcher wrote:
I am now in possession of an Android phone, so I can debug this... and I cannot reproduce this. On both mobile Chrome and Firefox, I was able to enable notifications, which were then delivered as they should be. Is there any additional information you can provide to help me figure out the problem?
On FF mobile (version 88.1.1 running on a Samsung Galaxy S7 Edge)  I initially see this on my Account > Notifications screen:




When I tap the Enable Notifications button, the screen starts to refresh and momentarily, I see this:




When the screen refresh completes, the screen is showing the first of the images in this message again.   I see the same thing happening in Chrome Mobile too.  I have tried clearing cookies and cached data etc. from both browsers but that seems to make no difference.

Regards
Andy


 

On Sun, Apr 18, 2021 at 8:53 AM Andy Wedge <andy_wedge@...> wrote:
On Thu, Jan 21, 2021 at 05:21 PM, Andy Wedge wrote:
I can no longer set notifications on Firefox mobile on my Android phone.
Trying to give this a nudge. I cannot set notifications on Chrome mobile either now.

I am now in possession of an Android phone, so I can debug this... and I cannot reproduce this. On both mobile Chrome and Firefox, I was able to enable notifications, which were then delivered as they should be. Is there any additional information you can provide to help me figure out the problem?

Thanks,
Mark


Andy Wedge
 

On Thu, Jan 21, 2021 at 05:21 PM, Andy Wedge wrote:
I can no longer set notifications on Firefox mobile on my Android phone.
Trying to give this a nudge. I cannot set notifications on Chrome mobile either now.

Thanks
Andy


Andy Wedge
 

Hi Mark,

following on from my last post about this I can no longer set notifications on Firefox mobile on my Android phone.  When I try to enable them, I see the 'Send A Test Notification' button but it does nothing. The device type/browser combination is not listed above that but the 'Disable Notification' button is shown which suggests it should be. If I tap the 'Disable Notification' button, I do get a prompt to confirm that action and if I confirm, I get back to the screen with the Enable option.  Doing a page refresh after trying the Enable and seeing the 'Send A Test Notification' button gives me the page with the Enable button again which seems to confirm it hasn't actually been set.



Regards
Andy