Topics

moderated Web notifications now enabled #update


Andy Wedge
 

On Wed, Jun 17, 2020 at 05:08 PM, Mark Fletcher wrote:
I've added some debugging information to the notifications page when viewed by your test account Andy. Can you try again and then send a screenshot of this debugging info?
Hi Mark,

I didn't see any debugging information on the notifications screen but this time I was able to turn notifications on in Firefox mobile and the test notification worked also.

Thanks,
Andy


 

On Tue, Jun 16, 2020 at 10:27 PM Andy Wedge <andy_wedge@...> wrote:

having previously disabled notifications on all devices I cannot test that now because as I said in previous posts the Enable Notifications In This Browser and Send A Test Notification buttons do not work on mobile Firefox.

I've added some debugging information to the notifications page when viewed by your test account Andy. Can you try again and then send a screenshot of this debugging info?

Thanks,
Mark 


Andy Wedge
 

On Wed, Jun 17, 2020 at 04:04 PM, Bruce Bowman wrote:
Reset groups.io permissions in Chrome and turned notifications back on again...no dice.
That's weird. I have the same settings in Chrome as you at that point and it works for me (on Chrome mobile also).  It's Firefox mobile that I have a problem with at present as I can't enable notifications.

I did have a problem with Firefox (Windows) not passing notifications to the Windows Action Centre but found a fix for that by changing the Firefox config setting alerts.useSystemBackend to true.

Andy


Bruce Bowman
 

On Wed, Jun 17, 2020 at 10:28 AM, Andy Wedge wrote:
a daft question perhaps but have you enabled the notifications in your account profile?
Yep. Turned it off and on...three times. Reset groups.io permissions in Chrome and turned notifications back on again...no dice. Even clicking the "Send a Test Notification" button doesn't seem to achieve the objective. Wondering now if there will ever be a desktop app.

Bruce


Andy Wedge
 

On Wed, Jun 17, 2020 at 03:17 PM, Bruce Bowman wrote:
But maybe I'm missing some fine point,
Hi Bruce,

a daft question perhaps but have you enabled the notifications in your account profile?

Regards,
Andy


Bruce Bowman
 

On Tue, Jun 16, 2020 at 02:45 AM, Shal Farley wrote:
I'm with you. Although I see the new UI controls (drop-list for moderator notifications, checkbox for hashtags) I don't see any hint of notifications, even when I deliberately take an action that should provoke one.

I checked Firefox's exclusion list for sites where I've blocked notifications, Groups.io was not in that list. I've now added it as Allowed. I turned off Cortana's hiding of notifications because it thought I had a window full screen somewhere.
I'm stuck, too. 

I think I have notifications enabled (see screenshot) but somehow it's still not happening.



W10 64-bit with Chrome Version 83.0.4103.97.

Another thought:  Hashtags are only created for a group as they begin to appear in group emails. If they are to be the primary means of managing notifications, this suggests that there's no way to be proactive about it. Hashtag by hashtag, you have to wait until that first email is posted before the corresponding "push" notification can be turned on.

But maybe I'm missing some fine point, because I'm pretty confused about this new feature.

Regards,
Bruce


Andy Wedge
 

On Tue, Jun 16, 2020 at 11:36 PM, Mark Fletcher wrote:
I've tweaked the record size setting again based on another bug report I found on-line. Can you try mobile Firefox again? 
 
Hi Mark.

having previously disabled notifications on all devices I cannot test that now because as I said in previous posts the Enable Notifications In This Browser and Send A Test Notification buttons do not work on mobile Firefox.

Regards,
Andy


 

Hi Andy,

On Tue, Jun 16, 2020 at 1:47 PM Andy Wedge <andy_wedge@...> wrote:

Still no notifications via FF on my mobile even though my account status showed the were active for Windows FF and Android FF. I've now gone through the following steps:


I've tweaked the record size setting again based on another bug report I found on-line. Can you try mobile Firefox again? 

Thanks,
Mark


 

In Mac system preferences --> notifications, I have all of the following checked for FF:

Show notifications on lock screen

Show in Notification Center: 5 Recent Items

Badge app icon

Play sound for notifications

--

J

Messages are the sole opinion of the author, especially the fishy ones.
My humanity is bound up in yours, for we can only be human together. - Desmond Tutu


 

On Tue, Jun 16, 2020 at 02:45 PM, Thomas Gruber wrote:
I had to allow notifications from Firefox in the control panel / notification settings,
Oh, you mean from the Mac. I'll look there again.
 
--
J

Messages are the sole opinion of the author, especially the fishy ones.
My humanity is bound up in yours, for we can only be human together. - Desmond Tutu


 

Also, on the Notifications settings page itself, I see this:
"The following websites have requested to send you notifications."
[Note: it is blank - there are none, but you could disallow any that are listed]

And at the bottom there's a checkbox (which is unchecked)
"Block new requests asking to allow notifications."

So, as the saying goes, "Something's not right."
--
J

Messages are the sole opinion of the author, especially the fishy ones.
My humanity is bound up in yours, for we can only be human together. - Desmond Tutu


Andy Wedge
 

On Tue, Jun 16, 2020 at 10:02 PM, Duane wrote:
On Tue, Jun 16, 2020 at 03:47 PM, Andy Wedge wrote:
1- The Enable Notifications In This Browser button does nothing
I had that problem yesterday when I played with this a bit.  It was because of a setting in FF on the Privacy & Security page, under Permissions, Notifications.  Could that be set to "Block new requests"?
Hi Duane,

that navigation sequence appears to be for the desktop version of FF. I get notifications with that, it's the mobile version that I cannot get notifications on.

Andy


 

I found Notifications help in FF and it looks really complicated. Haven't read it yet, but here's the link, in case it sheds any light on this for anyone else. Will read it later tonite
https://support.mozilla.org/en-US/kb/push-notifications-firefox?as=u&utm_source=inproduct
--
J

Messages are the sole opinion of the author, especially the fishy ones.
My humanity is bound up in yours, for we can only be human together. - Desmond Tutu


 

I already disabled DoNotDisturb (bummer), to no avail. I haven’t been able to find anything in FF to explicitly enable notifications - just ways to turn them off. I’ll search again.


On Jun 16, 2020, at 2:45 PM, Thomas Gruber <computerhusky@...> wrote:

And 1 more, with some additional info:
Firefox on Mac - latest version.
this is a bit tricky, at least it was for me. I had to allow notifications from Firefox in the control panel / notification settings, and I also had to disable my „do not disturb“ setting which is currently active, to make the notifications appear. After that, notifications on the Mac now also work in Firefox for me.
Kind regards
Thomas



Am 16.06.2020 um 23:20 schrieb Thomas Gruber <computerhusky@...>:

Hi,
Addition to my previous message:
Notifications work for me in Firefox as well, FF 70.0.1 in windows 10 1803 (yes, both a bit old, I agree).
I upgraded FF to 77.0.1 and it’s also working in this version.

Thomas


Am 16.06.2020 um 22:47 schrieb Andy Wedge <andy_wedge@...>:

On Tue, Jun 16, 2020 at 07:54 PM, Mark Fletcher wrote:
TIL Firefox mobile restricts the size of the notification payload. It should be fixed now. Hopefully.
Still no notifications via FF on my mobile even though my account status showed the were active for Windows FF and Android FF. I've now gone through the following steps:

1- Disable notifications on all devices (from my laptop)
2- Re-enabled notifications on my laptop
3- Sent test notification from laptop - received OK
4- check notification status from FF mobile and see this:
<dummyfile.0.part>

Issues/Questions:

1- The Enable Notifications In This Browser button does nothing
2- The Send A Test Notification button does nothing
3- Unsure why there is an Enable and Disable button for In This Browser - shouldn't one button toggle the option?
4- Tried Disable Notifications In This Browser button and tapped Yes on the verify pop-up panel - no changes to screen information or button options
5 -Tried Disable Notifications On All Devices button and tapped Yes on the verify pop-up panel - Screen updated to remove Windows Firefox details and Disable Notifications On All Devices button removed also - confirmed change by checking notification status on laptop

It's clearly not happy!?

Andy







--
J

Messages are the sole opinion of the author, especially the fishy ones.
My humanity is bound up in yours, for we can only be human together. - Desmond Tutu


Thomas Gruber
 

And 1 more, with some additional info:
Firefox on Mac - latest version.
this is a bit tricky, at least it was for me. I had to allow notifications from Firefox in the control panel / notification settings, and I also had to disable my „do not disturb“ setting which is currently active, to make the notifications appear. After that, notifications on the Mac now also work in Firefox for me.
Kind regards
Thomas



Am 16.06.2020 um 23:20 schrieb Thomas Gruber <computerhusky@...>:

Hi,
Addition to my previous message:
Notifications work for me in Firefox as well, FF 70.0.1 in windows 10 1803 (yes, both a bit old, I agree).
I upgraded FF to 77.0.1 and it’s also working in this version.

Thomas


Am 16.06.2020 um 22:47 schrieb Andy Wedge <andy_wedge@...>:

On Tue, Jun 16, 2020 at 07:54 PM, Mark Fletcher wrote:
TIL Firefox mobile restricts the size of the notification payload. It should be fixed now. Hopefully.
Still no notifications via FF on my mobile even though my account status showed the were active for Windows FF and Android FF. I've now gone through the following steps:

1- Disable notifications on all devices (from my laptop)
2- Re-enabled notifications on my laptop
3- Sent test notification from laptop - received OK
4- check notification status from FF mobile and see this:
<dummyfile.0.part>

Issues/Questions:

1- The Enable Notifications In This Browser button does nothing
2- The Send A Test Notification button does nothing
3- Unsure why there is an Enable and Disable button for In This Browser - shouldn't one button toggle the option?
4- Tried Disable Notifications In This Browser button and tapped Yes on the verify pop-up panel - no changes to screen information or button options
5 -Tried Disable Notifications On All Devices button and tapped Yes on the verify pop-up panel - Screen updated to remove Windows Firefox details and Disable Notifications On All Devices button removed also - confirmed change by checking notification status on laptop

It's clearly not happy!?

Andy







Thomas Gruber
 

Hi,
Addition to my previous message:
Notifications work for me in Firefox as well, FF 70.0.1 in windows 10 1803 (yes, both a bit old, I agree).
I upgraded FF to 77.0.1 and it’s also working in this version.

Thomas


Am 16.06.2020 um 22:47 schrieb Andy Wedge <andy_wedge@...>:

On Tue, Jun 16, 2020 at 07:54 PM, Mark Fletcher wrote:
TIL Firefox mobile restricts the size of the notification payload. It should be fixed now. Hopefully.
Still no notifications via FF on my mobile even though my account status showed the were active for Windows FF and Android FF. I've now gone through the following steps:

1- Disable notifications on all devices (from my laptop)
2- Re-enabled notifications on my laptop
3- Sent test notification from laptop - received OK
4- check notification status from FF mobile and see this:
<dummyfile.0.part>

Issues/Questions:

1- The Enable Notifications In This Browser button does nothing
2- The Send A Test Notification button does nothing
3- Unsure why there is an Enable and Disable button for In This Browser - shouldn't one button toggle the option?
4- Tried Disable Notifications In This Browser button and tapped Yes on the verify pop-up panel - no changes to screen information or button options
5 -Tried Disable Notifications On All Devices button and tapped Yes on the verify pop-up panel - Screen updated to remove Windows Firefox details and Disable Notifications On All Devices button removed also - confirmed change by checking notification status on laptop

It's clearly not happy!?

Andy






Thomas Gruber
 

hi Mark,
just a confirmation - for me it works in Chrome (Windows 10 and Mac OS X Catalina), and in Edge on Windows 10. That's the "old" Edge I think, the version that comes with Windows 10 1909 as standard .
Kind regards
Thomas


Duane
 

On Tue, Jun 16, 2020 at 03:47 PM, Andy Wedge wrote:
1- The Enable Notifications In This Browser button does nothing
I had that problem yesterday when I played with this a bit.  It was because of a setting in FF on the Privacy & Security page, under Permissions, Notifications.  Could that be set to "Block new requests"?

Duane


Andy Wedge
 

On Tue, Jun 16, 2020 at 07:54 PM, Mark Fletcher wrote:
TIL Firefox mobile restricts the size of the notification payload. It should be fixed now. Hopefully.
Still no notifications via FF on my mobile even though my account status showed the were active for Windows FF and Android FF. I've now gone through the following steps:

1- Disable notifications on all devices (from my laptop)
2- Re-enabled notifications on my laptop
3- Sent test notification from laptop - received OK
4- check notification status from FF mobile and see this:


Issues/Questions:

1- The Enable Notifications In This Browser button does nothing
2- The Send A Test Notification button does nothing
3- Unsure why there is an Enable and Disable button for In This Browser - shouldn't one button toggle the option?
4- Tried Disable Notifications In This Browser button and tapped Yes on the verify pop-up panel - no changes to screen information or button options
5 -Tried Disable Notifications On All Devices button and tapped Yes on the verify pop-up panel - Screen updated to remove Windows Firefox details and Disable Notifications On All Devices button removed also - confirmed change by checking notification status on laptop

It's clearly not happy!?

Andy





 

No, no problem, I was actually glad you answered to see that we’re using the same version of FF. Why mine diesnt work is a mystery.


On Jun 16, 2020, at 12:44 PM, Andy Wedge <andy_wedge@...> wrote:

On Tue, Jun 16, 2020 at 07:45 PM, J_Catlady wrote:
Not sure who that question was addressed to
Apologies, I think was actually addressed to you but as I was also reporting FF issues I responded.

Andy

--
J

Messages are the sole opinion of the author, especially the fishy ones.
My humanity is bound up in yours, for we can only be human together. - Desmond Tutu