Topics

moderated "locked" icon disappears from topics in results of a hashtag filter/search #bug #fixed


 

If you lock a topic, and the topic has a hashtag, and then you click on that hashtag anywhere, the topic appears in the hashtag search but the lock icon does not appear. I just went through re-locking a bunch of topics that I thought I'd already locked, and it turned out that I HAD already locked them. It's just that when looking for them by clicking on any hashtag they have, the locked icon had disappeared.
--
J

Messages are the sole opinion of the author, especially the fishy ones.
My humanity is bound up in yours, for we can only be human together. - Desmond Tutu


 

Here is a refinement of the bug:
The lock icon does disappear in a hashtag search if the topic was locked by hand.
But it does not disappear if the topic was locked via some hashtag.
--
J

Messages are the sole opinion of the author, especially the fishy ones.
My humanity is bound up in yours, for we can only be human together. - Desmond Tutu


 

The bug is worse than I thought. With the sole exception of topics that were locked via a hashtag, the lock icon fails to appear in *any* search that returns a message or topic, not just a hashtag search.

If you search on a term that returns the topic, the topic does not appear locked. Yet if you're looking at the topic or message in the message list (not the result of a search), the lock icon does show up.

It's not for us to give priority to bugs, but this would be at the top of my list if I could make one. I am repeatedly trying to lock topics via some search, and the lock icon keeps failing to appear. and I keep locking them over and over again - until I get out from the search, look at the full message list, and see the  lock icon there.
--
J

Messages are the sole opinion of the author, especially the fishy ones.
My humanity is bound up in yours, for we can only be human together. - Desmond Tutu


 

On Sat, Feb 22, 2020 at 03:06 PM, J_Catlady wrote:

If you lock a topic, and the topic has a hashtag, and then you click on that hashtag anywhere, the topic appears in the hashtag search but the lock icon does not appear. I just went through re-locking a bunch of topics that I thought I'd already locked, and it turned out that I HAD already locked them. It's just that when looking for them by clicking on any hashtag they have, the locked icon had disappeared.

This should be fixed now.

Thanks, Mark


 

Nearly fixed! They now show both the moderated and the locked icons when they are the results of search, whereas in the message list they show just the locked icon.
--
J

Messages are the sole opinion of the author, especially the fishy ones.
My humanity is bound up in yours, for we can only be human together. - Desmond Tutu


 

Hi J,

On Wed, Feb 26, 2020 at 8:51 PM J_Catlady <j.olivia.catlady@...> wrote:
Nearly fixed! They now show both the moderated and the locked icons when they are the results of search, whereas in the message list they show just the locked icon.

Off-list please send me the group name/search query that does this.

Thanks,
Mark