moderated Re: #bug Upload folder doesn't upload the folder. #bug


Andy
 

Back to other problems uploading Folders:

When a folder is uploaded, the message posted and sent to the group is wrong, the message sent to Moderators is wrong, and the Activity log information is partly wrong.  I uploaded a directory tree with 8 total files and some subdirectories in it.  The fact that there are subdirectories is not really relevant, but it is part of the problem too.  The message shows this:

The following files and folders have been uploaded to the Files area of the ...@groups.io group.

  • /Temp/File1.txt
  • /Temp/File2.txt
  • /Temp/File1.txt
  • /Temp/File2.txt
  • /Temp/File1.txt
  • /Temp/File2.txt
  • /Temp/File1.txt
  • /Temp/File2.txt

All eight lines are wrong!  Not only do they look wrong, but each line is a link, and each link goes to a nonexistent file.

My test uploaded folder was named "New" and was uploaded into the "/Temp" folder, so all files end up in a subdirectory of /Temp, and some are more than one level down.  Here is what it should have looked like:

  • /Temp/New/File1.txt
  • /Temp/New/File2.txt
  • /Temp/New/Sub/File1.txt
  • /Temp/New/Sub/File2.txt
  • /Temp/New/Sub/SubSub1/File1.txt
  • /Temp/New/Sub/SubSub1/File2.txt
  • /Temp/New/Sub/SubSub2/File1.txt
  • /Temp/New/Sub/SubSub2/File2.txt

and they should have links to match.

Lines in the Activity Log are partly incorrect.  The visible text in the log shows the same incorrect "/Temp/File1.txt" thing for all 8 files, but the links in the Activity Log appear to be correct, unlike the links in the messages.

My other complaint about it is that the messages do not show the folders that were created.  The Activity Log shows that the uploaded folder and its subfolders were created, but the messages to both the group and Moderators fail to show that any folder was created.

Regards,
Andy

Join main@beta.groups.io to automatically receive all group messages.