moderated Re: Unknown bounce issue #bug


Derek Milliner
 

Alexis,

First instinct is that the recipient machine running the script is throwing an error and breaking the SMTP connection without sending any message back to the sender; this might explain why the only entry in the 'Reason' is that HTML comment ((<!-- ). Various reasons for this, including:
  • Mail handler doesn't have permission to run the script
  • Mail handler doesn't have permission to read the script
  • Component required to run the script isn't present, is broken or has incorrect permissions/privileges (possibly due to being updated)
  • Non-printing character embedded in script, often due to cut & paste between dissimilar OSes (e.g. Windows -> Linux) causing a syntax error

There may be others of course, but without knowing the setup it's speculation right now. I presume from the way you describe the process that you have a script that generates a message which is posted to the group, the message then being delivered to members and processed by the second script. It's highly unlikely to be a problem at the Groups.io send given that only this one account has the issue.

 

I would try manually connecting to the recipient's mail server and emulating the delivery process with SMTP commands (EHLO, RCPT TO, MAIL FROM, DATA etc.); this would at least indicate whether it's possible to make a successful delivery (get an SMTP '250' code back). If you have a sample message it can be pasted in after the DATA command to try & generate an expected reply.

If the manual process doesn't work either, then it's a question of the user checking their system & logs to try and nail down the cause of the problem. 

Join main@beta.groups.io to automatically receive all group messages.