moderated possible bug in confirmation/application flow #bug #misc


 

I'm not sure what to call this, or whether it's a bug.

I've noticed that sometimes we get a pending member who is not marked NC (so they have confirmed), and whose last email delivery shows as "Confirmation Message." These are members who applied via the web, which means that the confirmation message was sent because it's the first group they're joining. (Members who already have a groups.io account and who apply to a group via email also receive the equivalent of a confirmation message, although people will say here that it's "not really" a confirmation message. But we're not in that case so the terminology doesn't matter.)

Anyway, the issue is that it seems they never received the pending subscription message. Because if their last email delivery was the confirmation  message, and they're not marked NC, then they must have confirmed. And my understanding (if correct?) is that they're not sent a group's pending message (or shouldn't be) until they've confirmed. So, if correct, the steps are (a) receive confirmation message, (2) confirm, (3) receive the group's pending message. These applicants have been through (1) and (2) (they've confirmed, since they're not NC) but are still not showing that they've received the pending member message, so they're missing (3).

In these cases I always resend the pending message, because it looks to me like they never got it. But I would like to know what's happening, and whether my understanding is correct. If so, this would seem to be a bug.
--
J

Messages are the sole opinion of the author, especially the fishy ones.
My humanity is bound up in yours, for we can only be human together. - Desmond Tutu

Join main@beta.groups.io to automatically receive all group messages.