... I'm a little concerned that "Notice" (especially "Member Notice")Hmm... I hadn't thought of that.
I'd like to say that they really are the same, as both are sent direct to the member. But that's not true of Guidelines and Monthly, which are Group Notices in my parlance (and in implementation, given their hashtags).
Also, the new ones are expected to be controlled by the member via their Subscription page; not so the ones defined in the group's Settings.
Nevertheless, I think I'd rather seek a way to work with this slight overlap in terminology than try to find some terminology that is non-overlapping but less clear for each application.
We could, for example, enhance the description of Guidelines and Monthly, in the group Settings, to say that they are exceptions - that they are in fact Group Notices. They are already exceptional in having a scheduled send rather than being tied to an action.
In a similar vein, it might make sense to describe the rest of them also under Member Notices. They would be distinct in that they already exist, and in that by nature they don't allow for user control.
Perhaps using "Notification" here, rather than "Notice," would helpI started off that way, but Notification is just so much baggage to carry around. It didn't seem right to me, and looking at my dictionary (yes, the dead trees kind) clarified why. As nouns, "notice" is the message, "notification" is the act of delivering it.
So that's what I went with: Web/App, Group, and Email Notification: describing the method used in the act of delivery. Then Moderator, Member, and Group Notices: describing the target of the notice.
As a further distinction, throughout the wiki and the Help CenterI do like staying consistent with standard English usage.
But I think we still need the distinction I made between the targets of the content; and we also need the distinction I made between the methods of delivery. It is the only way I can think of to make a sensibly organized description.
(I already intended to add "push notification.")I eventually backed away from the term "push", relegating it to "aka" status. I might go further and leave only the first of those references. My reason is that I didn't find it being used in browser or OS documentation, but I'll admit I only looked at the ones I use.