Topics

Message to +subscribe, re: display name


ajomccauley@...
 

Forking off topic #156

I'm thinking of using a basic webform on our website (it's Drupal so there's a webform module) that just sends a message to the "+subscribe" email address of our group.

The automatic email from the webform submission is like, kinda sorta from the submitting user's email address, and in my testing, it seems to work great -- but the Display Name isn't getting populated, and I can't figure out why.

Specifically: The email header of the email sent to "+subscribe" goes like this: (the "dots" are gmail formatting -- AFAIK the actual email uses <> like a normal.....)
From: Jane Doe via Our Website Name • admin@...
Reply-to: Jane Doe • jane@...

..........
So for whatever reason, the submitting user's email is handled the way I hoped, but not the display name -- like, the submitting user gets an email from Groups.io saying, "Please reply to this email to confirm your subscription request" or whatever (yay), and when the user replies, they're added as a pending group member and the group moderators get a notification email. ...But, the display name isn't populated.

To be honest, I was surprised it worked, given that the email isn't "from" the submitting user, it's just the "reply-to" that the submitting user's email address.  It's also interesting that the Display Name isn't populated with "Jane Doe" OR "Jane Doe via Our Website Name".

............
Does anyone know the exact way the "from name" in an email sent to a "+subscribe" email address needs to be formatted to make sure it populates the "Display name" on the resulting user account.....?

(Or, maybe there's a different question I should ask -- if so, pls feel free to answer That Question instead :D )

Thanks so much, everybody!
-Alison