Topics

Login produces an error of invalid email

Graham Lawrence
 

I have tried to login using POST with my email address and password but I get
array(3) {
  ["object"]=>
  string(5) "error"
  ["type"]=>
  string(13) "invalid email"
  ["extra"]=>
  string(0) ""
}
returned.
It might be that as I am just a subscriber to RIBI-Webmasters I am not authorised to use the API which I would like to do to perform an analysis of the posts.

Graham Lawrence



Patrick Dell'Era
 

I saw a similar error. Turned out it was nothing more than a character in my password that has specific meaning in the context of URLs and had to be encoded. See https://developer.mozilla.org/en-US/docs/Glossary/percent-encoding for more info.

--

Cheers,

Patrick

 

From: api@beta.groups.io <api@beta.groups.io> On Behalf Of Graham Lawrence
Sent: Sunday, December 1, 2019 10:11 PM
To: api@beta.groups.io
Subject: [api] Login produces an error of invalid email

 

I have tried to login using POST with my email address and password but I get

array(3) {
  ["object"]=>
  string(5) "error"
  ["type"]=>
  string(13) "invalid email"
  ["extra"]=>
  string(0) ""
}
returned.
It might be that as I am just a subscriber to RIBI-Webmasters I am not authorised to use the API which I would like to do to perform an analysis of the posts.

Graham Lawrence


 

On Sun, Dec 1, 2019 at 10:10 PM Graham Lawrence <Graham@...> wrote:
I have tried to login using POST with my email address and password but I get
array(3) {
  ["object"]=>
  string(5) "error"
  ["type"]=>
  string(13) "invalid email"
  ["extra"]=>
  string(0) ""
}
returned.


I saw some calls where no email address was sent. That would result in that error.

Mark

Graham Lawrence
 

Thank you, Mark, I have found the correct way to use the API.  It was simpler than I had assumed.
Graham